Error in sim of histogram-SMI example


#1

Hi,

I’ve been trying to migrate my designs to the new SMI protocol and have run into this error when simulating:

cd /opt/sdaccel-builder/eTeak && PATH=/opt/sdaccel-builder/eTeak/bin:/opt/sdaccel-builder/smi/bin:/opt/sdaccel-builder/go-root/bin:/opt/Xilinx/SDx/2017.1.op/bin:/opt/sdaccel-builder:/opt/Xilinx/SDx/2017.1.op/Vivado/bin:/opt/Xilinx/SDx/2017.1.op/bin:/opt/Xilinx/SDx/2017.1.op/Vivado/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin GOPATH="/mnt/.reco-work/vendor" /usr/bin/time -ao /mnt/times.out -f “verilog,%e,%M” ./go-teak-smi build --full-imports -O -p100 --ports 2 /mnt/main.go -o “/mnt/.reco-work/sdaccel/verilog”/main.v
go-teak-smi: /mnt/.reco-work/vendor/src/github.com/ReconfigureIO/sdaccel/verilog/sda_kernel_ctrl_param.v: openFile: does not exist (No such file or directory)
/opt/sdaccel-builder/sdaccel-builder.mk:118: recipe for target ‘"/mnt/.reco-work/sdaccel/verilog"/main.v’ failed
make: *** ["/mnt/.reco-work/sdaccel/verilog"/main.v] Error 1
334232e6-183e-4a84-9f9a-3a80fb7198e9

…I’m seeing the same error with the histogram SMI example (see above). I’m runnign with reco 0.5.1.

Any clues?

thanks,
Mark


#2

I’m seeing the same, or very similar, error when I run a build of the histogram-SMI example.


#3

Hi Mark,

It looks like the vendored sdaccel library needs an update. I’ll release a new version of examples shortly to cover that. In the meantime, if you delete the glide.lock file then run glide install (assuming you have a full go environment set up and glide installed) that will force an update of the library. I’ve just tested this process myself against the histogram-array-SMI example and this worked.

If you’re not using glide you can delete /vendor/github.com/ReconfigureIO/sdaccel and clone https://github.com/ReconfigureIO/sdaccel into its place.

Max


#4

Thanks Max, that seems to have fixed it.