🎉 Reconfigure.io v0.14.0 is released 🎉


#1

New Release v0.14.0
Optimizations and performance improvements

Upgrading

There is a new version of our tooling available. To upgrade, follow our installation instructions from step 2. You won’t need to re-authenticate your account.

To check what version you currently have installed, run reco version. The current version of our tooling is v0.3.1.

Once you are up to date, step 4 of our getting started guide now walks you through deploying our new in-browser MD5 example, so you can have a play with that too :slight_smile: .

New Optimisation Engine

Our engineers have introduced a new optimization engine focused on expressions. For example, during the compilation process, expressions like a + b + c + d would have previously generated 4 ‘adders’, which would take 4 clocks, but with this new optimization engine, this expression would only generate 3 ‘adders’ taking 2 clocks.

Ayup_1

Looking at the wider scope of this, we have taken an optimization step out of the development process, leaving it to be automatically handled by our compiler, and the resulting image, when deployed, will use up a reduced percentage of the FPGA’s available area.

Further Optimizations

Our compiler now inlines some small operator-only functions before other optimization passes, allowing subsequent optimatizations to exploit more information.

For a full rundown of features, see our release notes.


#2

Bugfix

A bugfix release for our tooling has gone out today. I’ve edited the reco version above to reflect this.

If you have already followed the reco update instructions above, you will need to go through them again to update to v0.3.1

Thanks!


#3

I installed the new version on Win7 using the installer but when I run reco version I get:

reco version: untracked dev build.

If I download the zip file and unzip to c:\reco then run reco version I get the expected output:

reco version: v0.3.1
Go version: go1.7.6
Build Time: 2017-11-23T16:10:51Z
Built By: Travis CI User travis@example.org


#4

Heya, I’d expect to see that behaviour if you’ve an old version of reco hanging around somewhere on your path. Try running the following in cmd (not powershell):

where reco

This finds all the reco.exes on your path, you should aim to have one and have that one be up to date.

In my case:

C:\Users\maxsi>where reco
C:\reco\reco.exe

I only have one, good start. If I then run C:\reco\reco.exe version I find that particular reco exe is v0.2.0, sorely out of date!

edit: the powershell version of where is where.exe


#5

I get the same as you.


#6

I’ve been really careful to always install to C:/reco.

If I install from the Installer, I get the issue - if I install just by
unzipping the archive, it works OK. Tried 3 times now.


#7

Oh I see what you mean, the version of reco bundled in the installer does not have proper version information while the archive version does. That’s a curious bug that I’ll take a look at tomorrow.

For now while it may claim to be an untracked dev build it is in fact v0.3.1 as it has all the features I’d expect to see for that version so you should be fine to use it.